Using AMOS tool for language pack translation

Problem with $a??

 
Picture of Miki Alliel
תשובה ל: Re: Problem with $a??
by Miki Alliel - Friday, 7 January 2011, 12:15 AM
Language pack maintainers

Yes  I understand what is it of course,

The thing is, that in moodle 1.9.x when we translated the string from english through the UI of moodle, we only copy the "$a" and paste it in the translation cell and it worked fine.

now I did it like that too.. ( copy paste it from the english side) and it switched between the chars  .

now when I wrote the "$a" , I'm writing first "$" and then "a" in the Hebrew cell which I suppose to write, but it switches the chars from some reason and this never happened in moodle 1.9 translation interface UI.

anyway I need to write now first "a" and then "$" - then it works..

Please click the 1st link you sent me here, I fixed it as you can see but if yousearch for "confirmdelete,report_unsuproles " you can see that the $a->role  and $a->level  are first shown as "a" and then "$" but it is ok because the link is empty from results.

you see something is really weird.

anout the 2nd link I fix it and it's ok.

 

this leads to another question:

is there a easy way to "find and replace" strings in the AMOS or will it be written?

 

Thanks