Using AMOS tool for language pack translation

Can AMOS be used for translation of versions prior to 2.0...

 
Picture of Bente Olsen
Can AMOS be used for translation of versions prior to 2.0...
by Bente Olsen - Monday, 24 January 2011, 9:42 PM
Language pack maintainers

or do you have to commit the older versions using cvs?

Picture of David Mudrák
Re: Can AMOS be used for translation of versions prior to 2.0...
by David Mudrák - Tuesday, 25 January 2011, 4:43 AM
Language pack maintainers

Translation of Moodle 1.x strings must be committed into CVS. Language pack maintainers have a merge tool available at the Stage page. So if there is a new string for Moodle 1.x, you can translate it in CVS first, wait an hour or so to give AMOS time to process your CVS commit and then merge new strings from 1.9 branch into 2.0 in AMOS.

Picture of Jeff Forssell
Svar: Re: Can AMOS be used for translation of versions prior to 2.0...
by Jeff Forssell - Saturday, 5 February 2011, 1:00 AM
 
It looked like AMOS could translate 1.9 strings so I did that and submitted to the maintainer. WIll that be useble?
Picture of David Mudrák
Re: Svar: Re: Can AMOS be used for translation of versions prior to 2.0...
by David Mudrák - Monday, 7 February 2011, 7:27 PM
Language pack maintainers

Hm, not really. That is actually a bug in AMOS. It should not let you translate strings for 1.x version as the maintainer does not have an option to export your contribution and commit it into CVS manually. It was a planned feature but this area has not been finished yet.

I can see two ways how to sort this out:

  • either implement a feature that lets the maintainer export the contributed translation into files so they can send it to CVS manually
  • or prevent translation of 1.x strings via AMOS

Suggestions? Comments?