Using AMOS tool for language pack translation

Can't see german strings for the Hot Potatoes module

 
Ralf Krause - Moodletreff.de
Can't see german strings for the Hot Potatoes module
by Ralf Krause - Monday, 21 February 2011, 12:18 AM
Language pack maintainers

Hi David

I 'm translating also the strings in the Hot Potatoes module but I can't see them on my test server.
The new Hot Potatoes module is installed in Moodle 2.0 and it is working but I do not get the german strings.

Could it be that the translated strings in AMOS are not connected with the new module. I hope you will help.

Ralf

Picture of David Mudrák
Re: Can't see german strings for the Hot Potatoes module
by David Mudrák - Wednesday, 2 March 2011, 6:23 AM
Language pack maintainers
Hi Ralf,

that sounds like a bug in Moodle then (and be related to yet another issue that was mentioned recently in Moodle developers chat). The de.zip language pack contains hotpot.php correctly. Let me look at this, I'll let you know.
Picture of David Mudrák
Re: Can't see german strings for the Hot Potatoes module
by David Mudrák - Wednesday, 2 March 2011, 6:05 PM
Language pack maintainers
Sorry Ralf, I can't reproduce this. I downloaded and installed Hotpot for 2.0 and the strings translated in the Czech language pack were immediately available, as expected...
Ralf Krause - Moodletreff.de
Re: Can't see german strings for the Hot Potatoes module
by Ralf Krause - Sunday, 20 March 2011, 12:56 AM
Language pack maintainers

Hi David,

I will try to show my problem. Our server uses Moodle 2.0.2+ (20110313).
The HotPotatoes modul was downloaded yesterday and it has the following version text.

$module->version  = 2010080321;
$module->release  = 'v3.0.21';
$module->requires = 2010080300;  // Requires this Moodle version

The attached three images are showing the problem.
You see the Website administration > Plugins > Activities > HotPotatoes settings in picture hotpot1.png

(1) Choosing the language packs de, de_du, or de_kids I always get the same results.
(2) The menus and the blocks are shown in german language.
(3) The strings in the HotPotatoes settings are in english language.

Next I open the settings when I at a new HotPotatoes activity to a courses. See hotpot2.png

(1) The language setting is still one of the german packs de_kids.
(2) The menus and the blocks are shown in german language.
(4)(5) The HotPotatoes strings are in english language.

At last I show you the translated strings in AMOS

(6) I hope that this hotpot is the correct component.
(7) Found german strings are 175 and no string is missing.
(8) This is the array of german strings.

Do you know what would be wrong?

Ralf

 




Ralf Krause - Moodletreff.de
Re: Can't see german strings for the Hot Potatoes module
by Ralf Krause - Sunday, 20 March 2011, 1:13 AM
Language pack maintainers

I added the problem to the tracker http://tracker.moodle.org/browse/MDL-26898