Using AMOS tool for language pack translation

UNTRANSLATED ERROR showing up

 
Picture of German Valero
UNTRANSLATED ERROR showing up
by German Valero - Thursday, 4 June 2015, 10:50 PM
Language pack maintainers

When I  try to run the cron command via web in a local 2.9 server, the following error message always appears in ENGLISH:

!!! Sorry, internet access to this page has been disabled by the administrator. !!!

The text within the triple exclamation marks is the same as cronerrorclionly in core_admin:

Sorry, internet access to this page has been disabled by the administrator.

Even though this string has been properly transated in AMOS and shows as translated in local language customization of my language pack in my server. I have purged the caches and repeated the test in a new 2.9 local install, with the same results.


I am therefore asking other translators to check this in their 2.9 servers, and if this odd behaviour is seen in other language packs, I would guess this is a bug which should be fairly easy to fix. THANKS in advance.

Picture of David Mudrák
Re: UNTRANSLATED ERROR showing up
by David Mudrák - Thursday, 11 June 2015, 5:47 PM
Language pack maintainers

Hi German.

The string is not hardcoded, the message properly uses the strings API. The thing is that admin/cron.php does not (by intentional design) use your session so that your current_lang() can not be observed. IIRC, it falls back either to the main site's language or English (not sure now). So it's actually not a bug imho.

Picture of German Valero
Re: UNTRANSLATED ERROR showing up
by German Valero - Thursday, 11 June 2015, 11:29 PM
Language pack maintainers

Thanks David,

Now I know.

I'll just add a page in the spanish documentation page, so that spanish-language users will know how to deal with this message.