Using AMOS tool for language pack translation

Missing language pack for 2.5dev branch

 
Picture of German Valero
Missing language pack for 2.5dev branch
by German Valero - Thursday, 6 December 2012, 3:42 AM
Language pack maintainers

Hi David,

Those of us who have a .dev (HEAD) Moodle branch to try the newly created English (and newly translated) language strings in a local server will see the error "cURL request for "http://download.moodle.org/langpack/2.5/languages.md5" failed, HTTP response code: HTTP/1.1 404 Not Found" when we try to automatically update any installed language pack within a 2.5dev (HEAD) local/real server.

This will show as "Because Moodle can not connect to download.moodle.org, we are unable to do language pack installation automatically. Please download the appropriate zip file(s) from http://download.moodle.org, copy them to your /Applications/MAMP/data/moodle24/lang/ directory and unzip them manually."

Are there any plans to have a 2.5dev language pack version for all languages available in AMOS and download.moodle.org in the near future ?

Having to manually erase the old language pack, download the new language pack, and unzip it to the right folder is way slower than the 1-click "update all installed languages"  button; specially when someone wants to try a new plugin translation for typos or wrong-meaning-of-word-used. I get a lot of these mistakes (that I later fix) because the meaning of many english and spanish words and phrases depend on the context they are used.

btw: Maybe we could change the message "Because Moodle can not connect to download.moodle.org, we are unable to do language pack installation automatically" to "Because Moodle can not retrieve the appropriate file from download.moodle.org, we are unable to do language pack installation automatically", as this would be more accurate in this case (and all others as well).

And, do you know when will be the change from  2.4dev to 2.4 and the addition of the new 2.5dev branch within AMOS branch selector ?. (Which I guess you are already working-at, as you have not answered some posts recently).

Thanks in advance for your help.

Picture of David Mudrák
Re: Missing language pack for 2.5dev branch
by David Mudrák - Wednesday, 12 December 2012, 7:34 PM
Language pack maintainers

> Are there any plans to have a 2.5dev language pack version for all languages available in AMOS and download.moodle.org in the near future ?

Yes. Our standard procedure is to create new branch in AMOS shortly after the release. Please note that at the moment, there is still no actuall 2.5dev-only development. Only fixes for 2.4 are sent there, too. So you don't really need to test 2.5 yet.